Facebook Shops wrong Catalog

Updated on July 24, 2024

Full error name: “Facebook Shops wrong Catalog”

Cause

You have probably added the wrong Business Page at the beginning of the setup process.

Solution

Connect the right Catalog:

  1. Remove your currently connected Page.
  2. Connect the correct one.

Here you can read a detailed step-by-step guide with pictures ->

In short. First thing to do is to clear the connection with Facebook.

  1. Disconnect Meta Commerce from Nembol.
  2. Go to your Facebook Personal Profile.
  3. Go to your Settings and Privacy > Settings.
  4. Scroll down the left menu and select “Business Integrations”
  5. Remove Nembol.
settings facebook

Once done, let’s add the correct Catalog. Go back to myapp.nembol.com and:

  1. Go to your Channels Tab.
  2. Click on the “Connect channels +” button.
  3. Choose Meta Commerce.
  4. You will be taken to Facebook. Click on “Continue as + your Name”.
  5. Click on “View Access”.
  6. By ticking them on, associate only the Business Page for which you want to use Nembol with.
  7. Click on continue.
  8. Confirm, and all is done.
grant permissions facebook